Page tree
Skip to end of metadata
Go to start of metadata

Requirements

Unimus is supported on:

  • Raspberry Pi 2
  • Raspberry Pi 3

We do not support running Unimus on RPi 1 or RPi Zero.

Supported OS:

  • Raspbian Stretch
  • Raspbian Jessie

We do not officially support running Unimus on any other OS on Raspberries.

Installing Unimus

wget https://unimus.net/download/linux/install.sh
chmod +x install.sh
./install.sh

Security note: it is dangerous running unknown scripts from the internet.
Please always review the script source before running it on your machines.

After the installer finishes, you can access Unimus at:
http://localhost:8085/
(substitute 'localhost' for the address of your Unimus server)

We recommend taking a look at this article on how to configure Unimus:
Initial configuration > Configuration wizard

Limitations

Please note Unimus can take a longer time to start on a RPi.
Allow up to 3 minutes for the service to start, and the web GUI to start responding.

We do not recommend managing more than 100 devices in Unimus instances running on Raspberry Pis.
The Unimus web GUI may become slow, or even unresponsive when many device operations are running.
(this is due to the performance limitations of the RPi)

We also recommend to only run HSQL (file-based DB) on RPi.
Please make sure you are using a high-speed SD card on your RPi.


  • No labels